XML Sitemaps Generator

Author Topic: Sitemap generation stuck at Time passed = 1 min 41 secs  (Read 9512 times)

dave60

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Sitemap generation stuck at Time passed = 1 min 41 secs
« on: November 12, 2012, 09:49:24 AM »
Hi,

I have run the Sitemap generation several times but each time it gets stuck when the script has been running for 1 min and 41 secs . This is the information is displays once is gets up to this point:

Links depth: 3
Current page: store/shopreviewlist.asp?id=258
Pages added to sitemap: 619
Pages scanned: 762 (15,903.0 KB)
Pages left: 224 (+ 325 queued for the next depth level)
Time passed: 0:01:41
Time left: 0:00:29
Memory usage: 1,886.6 Kb

I have looked through this forum for help and did find a topic similar to this, it suggested changing the 'max_execution_time' and 'memory_limit' in the php.ini file. This I have done. I have set 'max_execution_time to 200 (as this means no time limit is imposed), it was set to 30 previously. Also the 'memory_limit' was set to 8MB, I have now up it to 128MB. I have also changed the 'max_input_time' to 200.

The php.ini file I have been changed is located in C:\Windows\, is this the correct place? As you might have guessed I'm on a Windows Server (2008)

Are there any other settings that could be adjusted?
Do you have any other suggestions?

Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Sitemap generation stuck at Time passed = 1 min 41 secs
« Reply #1 on: November 12, 2012, 11:24:45 AM »
Hello,

you need to check the phpinfo() on your server to make sure that changes in php.ini were actually applied.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dave60

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Sitemap generation stuck at Time passed = 1 min 41 secs
« Reply #2 on: November 12, 2012, 12:17:03 PM »
Hi,

I checked phpinfo() and that gave me the correct php.ini to amend the values in. I did that and then checked phpinfo() again, and when I saw that max_execution_time was reading 200, I ran the crawling script, but it has stop around the same time again:

Links depth: 3
Current page: store/shopreviewlist.asp?id=244
Pages added to sitemap: 640
Pages scanned: 786 (16,437.6 KB)
Pages left: 200 (+ 331 queued for the next depth level)
Time passed: 0:01:39
Time left: 0:00:25
Memory usage: 1,894.7 Kb

Any ideas as to what else it could be?

Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Sitemap generation stuck at Time passed = 1 min 41 secs
« Reply #3 on: November 14, 2012, 12:07:12 PM »
Hello,

try to increase it to 9000 for instance.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dave60

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Sitemap generation stuck at Time passed = 1 min 41 secs
« Reply #4 on: November 15, 2012, 10:55:08 AM »
Hi,

Thanks for suggestion bu this has made no difference, also increased max_input_time to 9000 as well but still stopping at round about the same point:

Links depth: 3
Current page: store/shopreviewlist.asp?id=218
Pages added to sitemap: 570
Pages scanned: 698 (14,737.1 KB)
Pages left: 288 (+ 295 queued for the next depth level)
Time passed: 0:01:32
Time left: 0:00:38
Memory usage: 1,858.9 Kb

Regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Sitemap generation stuck at Time passed = 1 min 41 secs
« Reply #5 on: November 15, 2012, 10:43:24 PM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2