XML Sitemaps Generator

Author Topic: Invalid arguments and short sitemap.xml?  (Read 31051 times)

mark.hein

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Invalid arguments and short sitemap.xml?
« on: October 05, 2005, 03:23:55 PM »
Hello All,
O.K. I'm NOT a programer of apps by any means!! So please be gentle <G>...
When I open the index. html I get the following messages at the top of the page:
++++++++++++++++++++++
Warning: Invalid argument supplied for foreach() in /home/virtual/site28/fst/var/www/html/generator/index.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 48

Warning: Invalid argument supplied for foreach() in /home/virtual/site28/fst/var/www/html/generator/index.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 49

Warning: extract() expects first argument to be an array in /home/virtual/site28/fst/var/www/html/generator/index.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 52

Warning: extract() expects first argument to be an array in /home/virtual/site28/fst/var/www/html/generator/index.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 53[/table]
+++++++++++++++++++++++++++++++++++++++++

And although it's quickly done my sitemap.xml seems very "sparse":

++++++++++++++++++++++++++++++++++++++++++
<?xml version="1.0" encoding="UTF-8"?>
<urlset
  xmlns="[external links are visible to admins only]"
  xmlns:xsi="[external links are visible to admins only]"
  xsi:schemaLocation="[external links are visible to admins only]
                      [external links are visible to admins only]">

<url>
  <loc>[external links are visible to admins only]</loc>
  <lastmod>2005-06-30T19:35:14+00:00</lastmod>
  <changefreq>monthly</changefreq>
</url>
<url>
  <loc>[external links are visible to admins only]</loc>
  <lastmod>2005-06-30T19:35:14+00:00</lastmod>
  <changefreq>monthly</changefreq>
</url>
<url>
  <loc>[external links are visible to admins only]</loc>
  <lastmod>2005-06-30T19:35:14+00:00</lastmod>
  <changefreq>monthly</changefreq>
</url>
<url>
  <loc>[external links are visible to admins only]</loc>
  <lastmod>2005-06-30T19:35:14+00:00</lastmod>
  <changefreq>monthly</changefreq>
</url>
<url>
  <loc>[external links are visible to admins only]</loc>
  <lastmod>2005-06-30T19:35:14+00:00</lastmod>
  <changefreq>monthly</changefreq>
</url>
</urlset>
+++++++++++++++++++++++++++

My site is not "HUGE", but is rather large. Where in the settings/permissions have I gone wrong here?

Many thanks in advance for this program and your help......... Mark

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Invalid arguments and short sitemap.xml?
« Reply #1 on: October 05, 2005, 03:47:03 PM »
Hi Mark,

these warning messages appear because you have an older version of PHP than is recommended in generator documentation.
However, the script still works. :)

1. To solve the problem with only a small part of your site included in sitemap, you should enter FULL address as a "Starting URL:", in your case http://www.houseofhein.com/ instead of http://houseofhein.com/. (some of your links point to "www." address and are not followed since reside on another domain)
2. It seems like your sitemap is not stored because you didn't created sitemap.xml file as required. You should create this file and then set write permissions to it (0666).

Everything should work fine after that! :) (although the warnings will be shown ;))
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

mark.hein

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: Invalid arguments and short sitemap.xml?
« Reply #2 on: October 05, 2005, 04:05:45 PM »
Hey Friend,
I'll bet that's it!!
My Host is probably still using PHP3 and I did indeed change some of my a href's to www. since I'd been having fits with my ISP. They regenerated my Gateway last week and everything's working fine now.
(Pause)... I just changed the config settings to have all URL's with the "www." and I'll be back if any more fits arise. <G>
Again thanks for a fine app and your speedy help.... Mark

mark.hein

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: Invalid arguments and short sitemap.xml?
« Reply #3 on: October 05, 2005, 05:03:15 PM »
Yup, those were the problem(s)... All fixed....
And once again THANKS !!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Invalid arguments and short sitemap.xml?
« Reply #4 on: October 06, 2005, 09:26:53 AM »
Ok, excellent! :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2