XML Sitemaps Generator

Author Topic: Does not generate new sitemap and invalid argument warning  (Read 8515 times)

biker

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Does not generate new sitemap and invalid argument warning
« on: January 09, 2013, 11:53:36 AM »
I have installed and run XML unlimited sitemap and run the generator, which produced its first sitemap on January 3, 2013. I updated 7 pages on my website on January 4, 5, 6, and 7. 

Each evening when it runs the chron job to update the sitemap, I get this report:

504 | 2 | 4,120.6 | 0:00:25 | 0:00:00 | 2 | 1,887.5 Kb | 0 | 106 | 1887
<h4>Completed</h4>Total pages indexed: 0
<br>Creating sitemaps...
<div id="percprog"></div>
Creating HTML sitemap...<div id="percprog2"></div> |  | 0.0 | 0:00:00 | 0:00:00 |  |  |  |  | 0
<br />
<b>Warning</b>:  Invalid argument supplied for foreach() in <b>/home/rockybhd/public_html/generator/pages/class.gping.inc.php</b> on line <b>102</b><br />

-----------
I see the date of my sitemap never changed from the first one.  Also, it is giving me some warning that I have no idea what it means.

Will you explain, please, in non-techie terms?  I do not understand why it is not working the way it is supposed to work.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Does not generate new sitemap and invalid argument warning
« Reply #1 on: January 09, 2013, 04:15:45 PM »
Hello,

Looks like 0 pages are indexed for some reason.
Please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

biker

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: Does not generate new sitemap and invalid argument warning
« Reply #2 on: January 09, 2013, 06:53:01 PM »
Sorry, I cannot figure out where to send you a private message.  Please provide instructions or a different, secure method, to reach you.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Does not generate new sitemap and invalid argument warning
« Reply #3 on: January 09, 2013, 11:52:47 PM »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

biker

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: Does not generate new sitemap and invalid argument warning
« Reply #4 on: January 10, 2013, 03:24:26 PM »
Oleg, I am sorry that I cannot figure out how to send you a message with this system. It confuses me because it presents a blank "send to" screen without any address book. 

Anyway, I communicated with Philip at xml-sitemap.com support center. He looked at my site and told me that nothing was wrong with it, and got a new sitemap to generate while I never could do that.  Apparently, while he denies doing anything, he fixed something or I blundered into fixing it without knowing how I did it.

The cron job has not run yet, so I will let you know if that situation is fixed or not tomorrow.

Thank you for trying to help me. I sincerely appreciate it.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2