XML Sitemaps Generator

Author Topic: Fatal error message  (Read 10288 times)

woolfcom

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 23
Fatal error message
« on: August 12, 2013, 09:33:10 AM »
Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 74449036 bytes) in /home/content/98/xxxxx/html/xxxxx/pages/class.utils.inc.php on line 102

How do I fix this?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Fatal error message
« Reply #1 on: August 13, 2013, 07:55:41 AM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

woolfcom

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 23
Re: Fatal error message
« Reply #2 on: August 13, 2013, 10:19:48 AM »
I have just finished running a much larger crawl using the same installation?

So that cant be correct?


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Fatal error message
« Reply #3 on: August 16, 2013, 03:03:15 PM »
Memory usage depends on many factors, so it's still possible.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

woolfcom

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 23
Re: Fatal error message
« Reply #4 on: August 19, 2013, 02:14:51 PM »
what settings would you suggest?

I have set these

memory_limit = 100M
upload_max_filesize = 192M
post_max_size = 100M
file_uploads = On
max_execution_time 600
« Last Edit: August 19, 2013, 02:29:04 PM by woolfcom »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Fatal error message
« Reply #5 on: August 20, 2013, 10:02:16 PM »
There is a setting in generator configuration for memory limit, please try to set it to 512.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2