XML Sitemaps Generator

Author Topic: Hangs in the middle  (Read 5639 times)

dpkerr

  • Registered Customer
  • Approved member
  • *
  • Posts: 1
Hangs in the middle
« on: December 13, 2013, 06:07:22 AM »
I upgraded to the latest version 6.1 from 6.0 (which in itself had been previously upgraded).

No problem with 6.0 and earlier releases.

However, 6.1 sits there with the "crawling" message for ever (i.e. for hours). I can see that debug and log files do not change at all. If I stop it (by clicking stop on the web page), I can restart it and it finishes about 5 minutes later. Although, I can only tell it has finished by looking a the log file because the crawl page still says crawling.

I am only putting about 700 pages into the sitemap and total time is only about 7 minutes.

What would cause it to hang?

I have upgraded gallery2 to gallery3 and also Joomla 1.5 to 2.5 since the last successful runs (which I recall also told me progress through the crawl). I get no crawl progress messages at all.

Any clues?
Thanks,
Dave

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Hangs in the middle
« Reply #1 on: December 13, 2013, 12:23:48 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2