XML Sitemaps Generator

Author Topic: Process keeps stopping....  (Read 7546 times)

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Process keeps stopping....
« on: March 01, 2014, 10:32:28 PM »
I set this up yesterday, the few stats that appeared on the screen said it
would take 7 hours to complete, and that would be the last time I would see any
stats appear on the screen; the only thing I am seeing now where the stats should
be is a portion of my website with 404....not very useful to show me a picture
of my own website with 404 - what does that mean? the xml service shows you
stats at all times, even from page to page, you still see whats going on in the background.

So i wake up this morning thinking that I would see an email saying complete...
nope, not at all, what was I thinking, no interruption notice or anything, even
though I seem to be checking that box all the time. I am starting to feel like a
babysitter as I have re-started xml at least 20 or so times today, and I have no
idea what is going on because its not showing me anything, or telling me anything....
the process seems to stop a few minutes after I click re-start.

the only thing i can think of is xml is using too much resources, and the
server maybe automatically killing the process....

any ideas? 
« Last Edit: March 01, 2014, 10:43:53 PM by dscurlock »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Process keeps stopping....
« Reply #1 on: March 03, 2014, 04:16:48 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Moved to VPS > Errors
« Reply #2 on: March 06, 2014, 06:19:23 AM »
Warning: fopen(/home/autotool/public_html/sitemap/data/generator.conf): failed to open stream: Permission denied in /home/autotool/public_html/sitemap/pages/class.utils.inc.php on line 102

Warning: fclose() expects parameter 1 to be resource, boolean given in /home/autotool/public_html/sitemap/pages/class.utils.inc.php on line 104

Warning: Unknown: open(/home/autotool/public_html/sitemap/data//sess_e6fac084a8695008f11efff7bf9c1ad8, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/home/autotool/public_html/sitemap/data/) in Unknown on line 0

Think I have an idea about the last two, did not set permission to /data/
Have no clue about the the first two...

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Process keeps stopping....
« Reply #3 on: March 07, 2014, 08:09:51 PM »
I got it setup on a VPS now....
I started by running two sitemaps....

sitemap1 > ran quite fast, took 2.5 hours to finish
sitemap2 > ran quite slow, even a day after the first sitemap has finished,
it still runs quite slow, and times out fairly often, still not finished....

I would like to see an email option added for sitemaps that time-out
or stop running for whatever reason. When the first sitemap finished, at that
time I expected the 2nd sitemap would be near done, but it stopped running
like 15min into the process, if I would have been notified of it stopping, then
I could have restarted it quickly rathering then find out 3 hours after the first
sitemap had completed its run, so some type of email notification of a sitemap
that did not complete its process would be great, or at least an option to enable/
disable email notify of failed process....

Thanks


« Last Edit: March 07, 2014, 08:11:37 PM by dscurlock »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Process keeps stopping....
« Reply #4 on: March 10, 2014, 07:07:10 AM »
Hello,

sitemap1/sitemap2: that is for the same website I assume?
Please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Process keeps stopping....
« Reply #5 on: March 18, 2014, 05:08:11 AM »
no, sitemap1 = site1, sitemap2 = site2, etc...

I have a site that has 58k pages, and I just started sitemap, and I see no stats
at all running, its like all the fields are blank, and the cursor is spinning in
the upper/left hand corner of the screen, so I have no clue what it is doing....

but I can see my VPS stats....

CPU: 30%
CPU load: 2.25, 2.12, 2.08

Mem used: 794mb = 51.7% (that seems high)
Free Mem: 802mb / Total Mem: 1.5G

any of this useful...

btw, my sites are using cloudflare, is that a problem?

Ok, this sucks, something booted me out the sitemap page, not that i could
see anything anyway...I cant get back in as it will not load, so I assume the
sitemap is still running at the moment...any of this sound familer? I do not
expect it to run long as I have run it on a few 20k sites, and it timed out
more times then I change my underwear in a day, and I had the box checked
so that it would supposed to keep running even if I closed the browser....
but to be honest, I do not recall cpu/memory running this high....
« Last Edit: March 18, 2014, 05:44:49 AM by dscurlock »

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Process keeps stopping....
« Reply #6 on: March 18, 2014, 07:31:49 AM »
Looks like it ran for a good couple hours this time before it timed out...
but yet again, it times out again...I going to leave it where it is and
calling it a night...will try to finish the run tomorrow unless you have
something new to add on why it keeps stopping its process....
thanks

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Process keeps stopping....
« Reply #7 on: March 19, 2014, 03:35:42 AM »
It took all day, but after 4 more interruptions, the sitemap
for this site has been completed. Still do not really know
why the sitemap keeps getting interrupted in the first place....

dscurlock

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Process keeps stopping....
« Reply #8 on: March 19, 2014, 09:17:36 PM »
I guess I spoke too soon. The sitemap seems to be having trouble on
completing the final stage of building the sitemap. The highest I got was
80% complete before it died of error, and it is taking forever....

2nd run, error occured at 97% complete....

This really blows....

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Process keeps stopping....
« Reply #9 on: March 20, 2014, 10:17:39 AM »
Hello,

in this case it might help to run generator in command line if you have ssh access to your server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2