XML Sitemaps Generator

Author Topic: crawl doesn't complete, sitemap xml file is blank [IIS]  (Read 8794 times)

jonk

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
crawl doesn't complete, sitemap xml file is blank [IIS]
« on: November 21, 2014, 01:27:53 AM »
Update: I just found a similar thread. It says that we should increase some elements in php.ini. My questions are:

1. Where can I find php.ini on IIS?
2. What are the recommended values to set for each item considering a site with maximum 2000 URLs?

------------------------

I installed and configured the standalone script on IIS.

When I go to Crawling and click Run, the page loads, but after 5-10 minutes nothing happens (i don't get redirected to the "View sitemap" section. I also tried ticking the "run in background" option and checked back after 1 day and it says it crawled about 700 URLs (we have about ~1,200), however the XML file is still blank.

Can you do something about it?
« Last Edit: November 21, 2014, 01:32:42 AM by jonk »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: crawl doesn't complete, sitemap xml file is blank [IIS]
« Reply #1 on: November 21, 2014, 02:44:27 PM »
Hello,

1. location depends on the server configuration, you find location of the file on phpinfo() page.
2. please try 256M and 1000 seconds correspondingly for memory_limit and max_exection_time.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jonk

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: crawl doesn't complete, sitemap xml file is blank [IIS]
« Reply #2 on: November 21, 2014, 02:57:51 PM »
The values that I had setup when trying this were: memory limit 256 MB and max execution time 9000 seconds in the configuration

Is there something you can do to check?

This is the output from the latest attempt to crawl:

Links depth: 5
Current page:
Pages added to sitemap: 716
Pages scanned: 727 (66,421.2 KB)
Pages left: (+ 0 queued for the next depth level)
Time passed: 0:19:20
Time left: 0:00:00
Memory usage:
Resuming the last session (last updated: 2014-11-21 03:43:26)

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: crawl doesn't complete, sitemap xml file is blank [IIS]
« Reply #3 on: November 22, 2014, 02:01:28 PM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dahliasubasi

  • Registered Customer
  • Approved member
  • *
  • Posts: 1
Re: crawl doesn't complete, sitemap xml file is blank [IIS]
« Reply #4 on: March 19, 2015, 05:41:02 PM »
Hi! I have similar issue with the new version of the generator...
It is crawling but not generating any sitemap...
What should we do?

Thank you for your quick answer!

Paul

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: crawl doesn't complete, sitemap xml file is blank [IIS]
« Reply #5 on: March 20, 2015, 05:07:52 PM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2