XML Sitemaps Generator

Author Topic: error 500 problem  (Read 3624 times)

a1tgmoney3

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
error 500 problem
« on: February 17, 2016, 12:22:45 PM »
Hello,

My web hosting company has moved my site to a new server (windows 2012) and now I have problems with Sitemap generator, which has worked OK for years on the old server.

I have deleted all the old files and replaced them with the latest downloaded ones .

I have changed the configuration to suit the new server and allocated the necessary permissions to the data folder and the sitemap.xml file.

When I first run the crawl page I get a 500 error message, but when I check the log files there is no record of a 500 error for that page.

If I refresh the crawl page I then get the following information displayed:
=== === === ===
Already in progress. Current process state is displayed:

Links depth: 1
Current page: uk-bed-breakfast-Durham.htm
Pages added to sitemap: 133
Pages scanned: 136 (3,748.8 KB)
Pages left: 400 (+ 8173 queued for the next depth level)
Time passed: 0:01:31
Time left: 0:04:28
Memory usage: 3,834.5 Kb
=== === === ===
but the page just sits there with nothing else happening!

Can anyone tell me what I may have done wrong?

Many thanks

Tog
« Last Edit: February 17, 2016, 12:42:12 PM by a1tgmoney3 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: error 500 problem
« Reply #1 on: February 17, 2016, 03:52:54 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

a1tgmoney3

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: error 500 problem
« Reply #2 on: February 17, 2016, 04:09:13 PM »
Hello,

These are already set to 9000 and 128mb.

regards

Tog

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: error 500 problem
« Reply #3 on: February 17, 2016, 04:17:10 PM »
Please try a larger setting for memory_limit.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

a1tgmoney3

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: error 500 problem
« Reply #4 on: February 17, 2016, 04:21:18 PM »
The host won't let me. They say it is not within their policy and will only alow me the 9000 for 24 hours. In any case the page doesn't run for more than 2 minutes so there must be something else wrong

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: error 500 problem
« Reply #5 on: February 18, 2016, 06:03:45 AM »
Hello,

in this case I would recommend to run generator in command line if you have ssh access to your server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

a1tgmoney3

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: error 500 problem
« Reply #6 on: February 18, 2016, 09:34:28 AM »
This is getting way too technical for me.

I have now used a different sitemap generator that had no problems whatsoever and worked instantly.


Best regards

Tog
« Last Edit: February 19, 2016, 04:57:24 AM by XML-Sitemaps Support »

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2