XML Sitemaps Generator

Author Topic: Sitemap not crawling my blog posts  (Read 2774 times)

traderluke

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Sitemap not crawling my blog posts
« on: March 31, 2016, 10:49:40 PM »
I've tried using Pro-sitemap Generator several times but the crawler keeps missing my blog posts.  I'm not sure why this would be. Also, even though I've checked the option for it to crawl AJAX content, none of my AJAX pages are included in the sitemap. 

An example, of a blog post page is: [external links are visible to admins only]

There's a link to it on my homepage. 

An example, of a page with AJAX content is:
[external links are visible to admins only]

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Sitemap not crawling my blog posts
« Reply #1 on: April 01, 2016, 10:24:31 AM »
Hello,

1. canonical meta tag on that blog page points to a differrent URL:
<link rel="canonical" href="http://www.yourodmain.com/introducing-the-miami-real-estate-social-wall" />


2.  in order to index these pages it must comply with ajax crawling specs:
https://developers.google.com/webmasters/ajax-crawling/docs/getting-started
« Last Edit: April 04, 2016, 07:14:20 AM by XML-Sitemaps Support »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

traderluke

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Sitemap not crawling my blog posts
« Reply #2 on: April 01, 2016, 11:24:11 PM »
Thank you very much!  I have forwarded your response to my website developers.

Have a great weekend! 

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2