XML Sitemaps Generator

Author Topic: standalone sitemap generator not working properly!  (Read 1209 times)

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
standalone sitemap generator not working properly!
« on: December 14, 2016, 05:27:04 PM »
First I installed the test version and this worked properly.
Then I spent money, bought all extensions too and installed it.
And nothing works properly.
It runs WITHOUT displaying the crawling information at all.
Only states "Please wait .."
htop monitor shows high CPU usage
After a time, sometimes hours, the crawling windows says: "Internal Server Error"
php variables in php config set as recommended:
max_execution_time = 9000
max_input_time = 120
memory_limit = 768M
Reloading the page produce:
Continue the interrupted session
Updated on 2016-12-14 17:17:25 (250 seconds ago) , Time elapsed: 0:04:58,
Pages crawled: 38 (36 added in sitemap), Queued: 397, Depth level: 1
Current page: seminars-2000-en (5.5)
..
Continue the session seems not to work, as htop shows no extra load!
Also it shows please wait.
It is now a few days I am triing with sitemap generator.
What happened, was that starting in the evening and in the morning my site was dead and I had to restart the server.
P.S. PHP is using PHP 7
If it is not working, I would like get my money back.
It really is annoying, when the test version works and the payed version not!


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #1 on: December 15, 2016, 06:41:45 AM »
Hello, 

trial version has a built-in limit for the number of pages hence it usually wouldn't timeout before the limit is reached.
in this case I would recommend to run generator in command line if you have ssh access to your server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: standalone sitemap generator not working properly!
« Reply #2 on: December 15, 2016, 10:22:51 AM »
Just to make it clear:
1. The trial version scanned 500 pages very quickly.
2. The payed version only scans about 30 pages .. and finish then with error
3. the payed version never reached the 500 page limit!
Please do not tell me that there is not a severe bug, because it is definetely not the page limit of 500, which makes the difference between trial and payed version.
There is no documentation about running in command line????
How does it work?
What is the command?
How do I monitor?
Where do I set the configuration?



XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #3 on: December 15, 2016, 10:28:46 AM »
Hello,

the command line to use is displayed on Crawling page of sitemap generator:
php /path/to/generator/runcrawl.php

You will see the progress details shown after running the command.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: standalone sitemap generator not working properly!
« Reply #4 on: December 15, 2016, 10:53:01 AM »

-bash: /var/customers/webs/pj/joomla/web1/generator/runcrawl.php: Permission denied

.. seems you make it too simple.
Just don't work!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #5 on: December 15, 2016, 11:06:19 AM »
The command line should start with "php ".
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #6 on: December 15, 2016, 11:06:36 AM »
php[space]/path/to/generator/runcrawl.php
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: standalone sitemap generator not working properly!
« Reply #7 on: December 15, 2016, 11:10:14 AM »
command started.
But where is the progress shown?
Just see a blank line.
Can cancel with ctrl C???


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #8 on: December 15, 2016, 11:21:56 AM »
Can you provide temporary ssh access in private message to check this?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: standalone sitemap generator not working properly!
« Reply #9 on: December 15, 2016, 07:03:28 PM »
works now.
Hint: You have to open the generator page in your browser to see progress. In ssh it is nor shown.
Just still wonder why it works with ssh command and NOT from browser.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10706
Re: standalone sitemap generator not working properly!
« Reply #10 on: December 15, 2016, 07:54:13 PM »
Generator runs as a web script when started in browser which usually has more restrictions compared to ssh command line script.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

peter55

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: standalone sitemap generator not working properly!
« Reply #11 on: December 15, 2016, 08:19:27 PM »
Running in ssh needs check owner of generated files too!
someone should know how to use chown.

 

SMF 2.0.13 | SMF © 2014, Simple Machines
XHTML RSS WAP2