XML Sitemaps Generator

Author Topic: <lastmod> in generated sitemap wrong  (Read 3417 times)

des3

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
<lastmod> in generated sitemap wrong
« on: January 01, 2017, 07:23:44 PM »
Sitemap had been running happily on my server for several years.

Recently the <lastmod> field for pretty much all files is being returned as the date/time the crawl started not the last modified date/time.

I've done a clean install of the latest version but that hasn't fixed it.

Any suggestion very much appreciated.
« Last Edit: January 01, 2017, 07:38:08 PM by des3 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10913
Re: <lastmod> in generated sitemap wrong
« Reply #1 on: January 01, 2017, 08:08:37 PM »
Hello,

in case if your server doesn't return "Last-modified" http header it would be populated with current date/time.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

des3

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: <lastmod> in generated sitemap wrong
« Reply #2 on: January 03, 2017, 06:21:34 PM »
The supplier of my virtual server say they can't see anything wrong.

xml-sitemaps ran happily for several years before failing to log a useful last modified date/time.

Getting this as a header report:

Response Code   HTTP/1.1 200 OK
Date   Tue, 03 Jan 2017 18:20:31 GMT
Server   Apache/2.2.31 (Unix) mod_ssl/2.2.31 OpenSSL/1.0.1e-fips mod_bwlimited/1.4
Accept-Ranges   bytes
X-Mod-Pagespeed   1.11.33.4-0
Vary   Accept-Encoding,User-Agent
Content-Encoding   gzip
Cache-Control   max-age=0, no-cache
Content-Length   6661
Connection   close
Content-Type   text/html; charset=utf-8

Don't know what to do next:)

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10913
Re: <lastmod> in generated sitemap wrong
« Reply #3 on: January 04, 2017, 07:44:53 AM »
Hello,

as you can see there is no "Last-modified" header listed, it means that your website doesn't send it. You need to contact your website developer if you want to include it.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.14 | SMF © 2017, Simple Machines
XHTML RSS WAP2