Sitemap Generator has stopped working
« on: November 12, 2018, 03:01:12 PM »
Hi,

I upgraded to the latest version of the Sitemap Generator quite recently, but now it seems to have stopped working. I'm not sure what I've done wrong, file permissions etc. are all OK, but sitemap.xml is not having any data written to it. Any idea what I might be doing wrong?
Re: Sitemap Generator has stopped working
« Reply #1 on: November 13, 2018, 07:20:01 AM »
Hello,

what exactly is the error you get?
Re: Sitemap Generator has stopped working
« Reply #2 on: November 13, 2018, 08:27:22 AM »
I don't get any error - I start it crawling, nothing happens for a few minutes, then crawling stops, and the page refreshes to say x pages have been indexed (usually around 130 pages), however none of the pages the script is supposed to generate have any content, and remain at 0kb.

If I go back to the crawling page I get the option of resuming where it last left off.
Re: Sitemap Generator has stopped working
« Reply #3 on: November 14, 2018, 04:28:59 AM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Sitemap files are created only after the crawling is completed, i.e. it will remain 0b in size while crawling.
Re: Sitemap Generator has stopped working
« Reply #4 on: November 15, 2018, 11:10:34 AM »
Hi,

I upgraded to the latest version of the Sitemap Generator quite recently, but now it seems to have stopped working. I'm not sure what I've done wrong, file permissions etc. are all OK, but sitemap.xml is not having any data written to it. Any idea what I might be doing wrong?
I have the same problem : i have this message :
Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/31/d575783401/htdocs/gites/webroot/generator/pages/page-view.inc.php on line 114
You can see a screenshot in attachment...
Thank you for your help !