runcrawl.php version 8.1 fails with ssl errors
« on: July 19, 2021, 04:04:35 AM »
After updating from 8.0 to 8.1, running runcrawl.php from a shell fails with a whole bunch of ssl-related errors. I'm attaching a .txt file with the output that I got.

I never had this problem with version 8.0, so for now I'm going to downgrade, at least until I hear back from you.
Re: runcrawl.php version 8.1 fails with ssl errors
« Reply #1 on: July 19, 2021, 06:27:54 PM »
Hello,

Please try to enable "Use CURL" setting in generator configuraiton.
Re: runcrawl.php version 8.1 fails with ssl errors
« Reply #2 on: July 19, 2021, 08:54:00 PM »
The "Use CURL" was the very first thing that I tried, but I got the same error.

In fact, it looks like our web services provider has suddenly changed the firewall settings on the server without informing me, and has blocked local access to port 443. I confirmed this by trying both wget and lynx from the server shell, and in both cases, attempts to connect to my own website failed, whereas connections to other websites succeeded.

So this may not have anything to do with the upgrade from 8.0 to 8.1. I'll be contacting our provider about this, and will ask them to restore local https:// access. I'll let you know.