XML Sitemaps Generator

Author Topic: sitemap not in supported format error in Google, worked ok previously  (Read 16190 times)

robert g

  • Approved member
  • *
  • Posts: 6
Sitemap generated with Free Online Sitemap Generator worked fine for several months, thank you very much.
Sitemap address: [external links are visible to admins only]

Now Google webmaster tools show a "sitemap not in supported format" error. Sitemap is same as before, in xml-format, uploaded it again after the error message,  Google visited again, shows still the same error.

I'd much appreciate any ideas here; the sitemap looks exactly the same as before, tried blinking it with an older version, only the update times are different...

I did upload a .htaccess-file a few days ago; this contains only few simple 301 redirects of single pages from some old page addresses (same domain, different page), all the redirects work fine?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Hello,

please try to remove .htaccess file temporarily and see if that helps.
It's also possible that Google has temporary problem accessing your site if there were some changes on your host, you can try to resubmit sitemap after a couple of days.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

robert g

  • Approved member
  • *
  • Posts: 6
Hello admin,

I tried removing the .htaccess file, resubmitted to Google, shows the same sitemap format error, so it's not that.
Thank you for your reply anyway.

robert g

  • Approved member
  • *
  • Posts: 6
More information: Tried with a newly generated (Free Online Sitemap Generator) sitemap, this map has www prefixes in addresses, the older one did not; no change, same error.
Also tried a sitemap version with a capital S, Sitemap.xml, no change.

Webhotel support reports everything fine here... Googlebot seems to have stopped crawling the site, this can't be good.
Can't find any exotic letters, typos etc. (and it worked before); any ideas would be much appreciated.



XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Not sure if it's related, but I cannot open your sitemap now neither, it results in File not found error.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

robert g

  • Approved member
  • *
  • Posts: 6
... it's probably due to the sitemap having now a capital S, Sitemap.xml, not sitemap.xml, as yesterday.
(someone suggested to try that, no change, though)

Would you try with capital S, it seems to open ok from here?

robert g

  • Approved member
  • *
  • Posts: 6
Problem solved:

Replacing the whole, auto-generated "schema" part inside the upper urlset tag with a "Google" 0.84 schema made Googlebot happy.

Nobody seems to no why, exactly, the old schema suddenly stopped working, there was no obvious error in it..

q4legend

  • Approved member
  • *
  • Posts: 1
Hi, I am experiencing same trouble - though this is the first time I have tried a 'sitemap'

Can Robert (or someone else) please explain how you fixed the issue...

What is "Google 0.84 schema"?

TIA

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Hello,

what  is your sitemap URL?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

robert g

  • Approved member
  • *
  • Posts: 6
Hi q4legend,

You may want to google "google schema 0.84", and use the version ending to sitemap.xsd, to replace the old schema (all of it) at the top of the Sitemap, inside the top urlset tag: <urlsetINSERT_HERE>.
(The other 0.84-schema is for a sitemap index, for large sites.)

You'll need a xml editor, like XML Marker, to do this.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2