XML Sitemaps Generator

Author Topic: I can't get the generator to work for HTTPS (secure) site  (Read 15310 times)

lee9

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
I can't get the generator to work for HTTPS (secure) site
« on: May 26, 2009, 11:15:14 AM »
Hello

I have just purchased the Standalone generator.

I have 2 sites. I've correctly installed the software. I've saved the configuration for each site.

The sitemap is generated no problem for the HTTP site. However, it does not work for the HTTPS site. Running it from a command line in Linux (I have full admin access to the server) I get this output:

Code: [external links are visible to admins only]
<h4>An error occured: <b>There was an error while retrieving the URL specified:</b> http://secure.dnuk.com/<br><b>HTTP headers follow:</b><br>Tue, 26 May 2009 11:39:53 GMT<br>Apache/2.2.8 (Linux/SUSE)<br>PHP/5.2.6<br>https://secure.dnuk.com/store/index.php<br>0<br>close<br>text/html<br><b>HTTP output:</b><br></h4><script>
top.location = 'index.php?op=config&errmsg=%3Cb%3EThere+was+an+error+while+retrieving+the+URL+specified%3A%3C%2Fb%3E+http%3A%2F%2Fsecure.dnuk.com%2F%3Cbr%3E%3Cb%3EHTTP+headers+follow%3A%3C%2Fb%3E%3Cbr%3ETue%2C+26+May+2009+11%3A39%3A53+GMT%3Cbr%3EApache%2F2.2.8+%28Linux%2FSUSE%29%3Cbr%3EPHP%2F5.2.6%3Cbr%3Ehttps%3A%2F%2Fsecure.dnuk.com%2Fstore%2Findex.php%3Cbr%3E0%3Cbr%3Eclose%3Cbr%3Etext%2Fhtml%3Cbr%3E%3Cb%3EHTTP+output%3A%3C%2Fb%3E%3Cbr%3E'
</script>

Does anyone know how to fix this?

The site is fully working without any errors from a web browser. And Googlebot has no problem with the site.

Thank you.

Modifed to add: Yes, I am using version 3.0 which has HTTPS support.
« Last Edit: May 26, 2009, 11:20:54 AM by lee9 »

lee9

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: I can't get the generator to work for HTTPS (secure) site
« Reply #1 on: May 26, 2009, 11:38:46 AM »
Update - I have this working.

I was my error - I did not specify HTTPS in the configuration page.

Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: I can't get the generator to work for HTTPS (secure) site
« Reply #2 on: May 26, 2009, 10:12:05 PM »
I'm glad you got it working!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2