XML Sitemaps Generator

Author Topic: XML document must have a top level element  (Read 17223 times)

philipdhuy

  • Approved member
  • *
  • Posts: 3
XML document must have a top level element
« on: July 01, 2009, 12:53:30 PM »
Hi there
I have a site [external links are visible to admins only]
I have generated on-line a sitemap. This came up with the following error:
XML Parsing Error: no element found
Location: [external links are visible to admins only]
Line Number 1, Column 1:
I have copied the sitemap.xml to the root of the website.
When testing from your site I get the following error
XML document must have a top level element. Error processing resource '[external links are visible to admins only]...

Any ideas why this would happen?
regards Philip

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: XML document must have a top level element
« Reply #1 on: July 03, 2009, 05:47:02 AM »
Hello,

try to submit your sitemap to Google:
https://www.google.com/webmasters/tools/dashboard
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

philipdhuy

  • Approved member
  • *
  • Posts: 3
Re: XML document must have a top level element
« Reply #2 on: July 11, 2009, 02:56:00 AM »
I did put it forward to google and the site does come up when searching google.
I guess that is good, however I wonder why I receive errors when running your tool.

Philip

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: XML document must have a top level element
« Reply #3 on: July 12, 2009, 02:32:14 PM »
Yes, it means that sitemap is fine. Perhaps that was a temporary issue with w3c validator.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

philipdhuy

  • Approved member
  • *
  • Posts: 3
Re: XML document must have a top level element
« Reply #4 on: August 02, 2009, 11:48:06 PM »
Today I ran the generator again and it worked without a hitch.
Thanks, Philip

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2