XML Sitemaps Generator

Author Topic: Entire Folders Are Missing From SiteMap  (Read 9823 times)

john58

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Entire Folders Are Missing From SiteMap
« on: October 25, 2009, 07:48:27 AM »
I purchased this because I have sites with 1,000's of pages.  But, after installing and running the software, only the root and possibly one folder is included in the sitemap.  For example:  [external links are visible to admins only] - I have a few thousand pages under one folder fountains and a few thousand pages under another folder plants but, only 33 root pages show up in the sitemap.  I have these folders linked from my homepage and I haven't found any errors.

I have other websites where this very same folder structure seems to work but, only one folder and not any others.

I've reset my permissions to 777 on the folders and subfolders with no help.

Any advice?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Entire Folders Are Missing From SiteMap
« Reply #1 on: October 25, 2009, 08:01:26 AM »
Hello,

looks like your inner links are pointing to non-www domain, so please try to specify http://domain.com/ as Starting URL instead of http://www.domain.com
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

john58

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Entire Folders Are Missing From SiteMap
« Reply #2 on: October 25, 2009, 08:13:45 AM »
I just check my linksfrom my homepage leading to my "bulk file" folders and  they look like this:

[external links are visible to admins only]
[external links are visible to admins only]

No 'www' indicated. 

The only 'www' I see are links leading to the affiliate link like it's suppose to.

Obviously I'm not seeing something I should... could you please explain?

Thank you.

john58

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Entire Folders Are Missing From SiteMap
« Reply #3 on: October 26, 2009, 07:38:18 AM »
 ???  I've checked all my homepage index pages and none of them have starting links pointing to non-www domains.  That is clearly not the problem.  But the problem of whole folders and even some root files not being picked up still persists.  I've even taken out my robot.txt file to test and nothing changed.

I am missing something but 'www' doesn't seem to be the answer.  Anybody else have some ideas?  Could it be an issue with my ISP?  Could it be an issue with my site host?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Entire Folders Are Missing From SiteMap
« Reply #4 on: October 27, 2009, 03:58:04 PM »
Hello,

"non-www" means "pointing to a domain without www prefix", which is the case on your site. Did you try my suggestion posted above?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2