Win2003 IIS - Error opening socket to www.my-domain.com\
« on: February 21, 2011, 01:06:49 AM »
I installed this (Standalone Sitemap Generator (Trial Version)) on a windows server and a Linux server. Working in minutes on the Linux server. Hit the wall, hard, on the windows server.
Is it just me, or would the world be a better place if Microsoft left the Internet alone?

Anyway, it's Windows 2003 IIS. Sitemap generator delivers the following errors about 4 seconds after hitting the Run button:

There was an error while retrieving the URL specified: [ External links are visible to forum administrators only ]/
Error message: Error opening socket to [ External links are visible to forum administrators only ]
HTTP headers follow:

HTTP output:

I set permissions on the data folder in the IIS control panel. It won't let me set permissions on individual files, only folders. Here are the configuration setting generated, they look "odd" to me:
Configuration
-------------------------------
Starting URL:
[ External links are visible to forum administrators only ]

Save sitemap to:
D:\webs\my-account-name/sitemap.xml

Your Sitemap URL:
[ External links are visible to forum administrators only ]/sitemap.xml

Thanks in advance, any help is greatly appreciated.
Tom
Re: Win2003 IIS - Error opening socket to www.my-domain.com\
« Reply #1 on: February 21, 2011, 11:21:27 AM »
Hello,

please let me know your generator URL/login to check this: http://www.xml-sitemaps.com/contact.html
Re: Win2003 IIS - Error opening socket to www.my-domain.com\
« Reply #2 on: February 22, 2011, 03:29:10 PM »
Generator page is here:
[ External links are visible to forum administrators only ]
It's a customers site, I'm not at liberty to share the login.

I used your free online sitemap generator to create a sitemap for it. That seemed to work fine.
Thanks for your quick response, sorry I waited a day to respond.
Tom
« Last Edit: February 22, 2011, 03:40:44 PM by tlink211 »
Re: Win2003 IIS - Error opening socket to www.my-domain.com\
« Reply #3 on: February 22, 2011, 09:32:32 PM »
Hello,

you had an extra slash character in Starting URL. I've corrected it and it works now.
Re: Win2003 IIS - Error opening socket to www.my-domain.com\
« Reply #4 on: February 22, 2011, 09:47:36 PM »
Very good. Thank You. I tried to correct that, or really experiment with it but I didn't notice the "Save" button at the bottom.

I purchased the unlimited Sitemap Generator this afternoon. Ran it against a much larger site I have, local community newspaper. [ External links are visible to forum administrators only ]

Setup in minutes, ran perfect the first time. Thank You for a great tool!