XML Sitemaps Generator

Author Topic: There was an error while retrieving the URL specified...  (Read 11969 times)

gorsky

  • Approved member
  • *
  • Posts: 3
There was an error while retrieving the URL specified...
« on: March 24, 2011, 10:25:57 PM »
This message keeps popping up when I try to start the crawler.  I set my IP to 127.0.0.1 and this error is still popping up.  I've also tried leaving off the [external links are visible to admins only]  and the error is still there.  I am sitting here connected to my server and it's working just fine, and I know the URL itself is up and running.  Any other suggestions?

The full message reads:
There was an error while retrieving the URL specified: [external links are visible to admins only]
HTTP headers follow:
content-type: text/html
date: Thu, 24 Mar 2011 22:15:25 GMT
connection: close
content-length: 34

HTTP output:
Bad Request (Invalid URL)

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: There was an error while retrieving the URL specified...
« Reply #1 on: March 25, 2011, 03:33:23 PM »
Hello,

please let me know your generator URL/login  to check this: http://www.xml-sitemaps.com/contact.html
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

gorsky

  • Approved member
  • *
  • Posts: 3
Re: There was an error while retrieving the URL specified...
« Reply #2 on: March 25, 2011, 04:25:43 PM »
Can you make this a private message?  I'd rather not have the link posted for everyone to see, but I don't have permission to send you a direct message.

[external links are visible to admins only]

I did not set up a login yet so it will be whatever the default is.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: There was an error while retrieving the URL specified...
« Reply #3 on: March 27, 2011, 10:29:03 AM »
Probably there is a configuration problem - it looks like your server doesn't allow local network connections via port 80 (http) - as a result sitemap generator is not able to crawl the site. This is usually related to firewall installed at the host - could you please contact your hosting support regarding this?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

gorsky

  • Approved member
  • *
  • Posts: 3
Re: There was an error while retrieving the URL specified...
« Reply #4 on: March 28, 2011, 02:57:59 PM »
Our systems admin assures me this isn't the case.  Is there anything else I can try?  Right now it fluctuates between a "socket error" and "error while retrieving the URL specified".  This is getting very frustrating and I'm worried I wasted my money and should just try different software.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: There was an error while retrieving the URL specified...
« Reply #5 on: March 29, 2011, 08:40:29 PM »
Hello,

I just tried to change starting URL in your generator configuration to external website (google.com as an example), and crawler worked fine (limited it to 1 page for testing) - it means that the problem happens only when connecting to local site (same domain where generator is installed) and it's configured by an internal server firewall.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

staff5

  • Registered Customer
  • Approved member
  • *
  • Posts: 1
Re: There was an error while retrieving the URL specified...
« Reply #6 on: October 21, 2011, 04:23:42 PM »
Hi I had the same issue, it was because I had a temporary redirect from the home page, check your temp or perm redirects, also I was missing the "www" on the url portion ... once I changed both it worked like a charm!
Cheers!

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2