XML Sitemaps Generator

Author Topic: Warning-Message  (Read 30528 times)

René Haine

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Warning-Message
« on: November 27, 2006, 10:02:17 PM »
Hello
After installation, I changed CHMOD from DATA-folder and config.inc.php. The sitemap.xml is empty and CHMOD 666, so I go to index.php and get a warning

Warning: ini_set() has been disabled for security reasons in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/index.php(2) : eval()'d code on line 33
 ???
After different installations (zip and by 'normal FTP'), nothing changed.
So I tried to make, after configuration (without login and password saving - because with this, nothing works) a crawling of my site, I get following message

Warning: ini_set() has been disabled for security reasons in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/index.php(2) : eval()'d code on line 33

at the top
and after a while of crawling at the bottom

Warning: set_time_limit() has been disabled for security reasons in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 8

Fatal error: Maximum execution time of 30 seconds exceeded in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 302


So I have only one word to say

HELP  :P

Thanks
René Haine

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Warning-Message
« Reply #1 on: November 27, 2006, 10:11:24 PM »
Hello,

you can ignore warning messages, as for this error:
Quote
Fatal error: Maximum execution time of 30 seconds exceeded in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 302
You should increase max_execution_time setting in your php configuration to get sitemap generated without timeouts.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

René Haine

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Warning-Message
« Reply #2 on: November 27, 2006, 10:36:42 PM »
[external links are visible to admins only]
Hello,

you can ignore warning messages, as for this error:
Quote
Fatal error: Maximum execution time of 30 seconds exceeded in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 302
You should increase max_execution_time setting in your php configuration to get sitemap generated without timeouts.

After crawling a while, it's stoped and I got this


Warning: ini_set() has been disabled for security reasons in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/index.php(2) : eval()'d code on line 33
Links depth: 235
Current page: calendar/set.php?var=showglobal&from=day&cal_d=19&cal_m=8&cal_y=2007
Pages added to sitemap: 5897
Pages scanned: 5900 (36,334.1 Kb)
Pages left: 15 (+ 17 queued for the next depth level)
Time passed: 37:45
Time left: 0:05
Memory usage: 4,911.7 Kb

Warning: set_time_limit() has been disabled for security reasons in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 8
Resuming the last session (last updated: 2006-11-27 22:51:25)
Fatal error: Maximum execution time of 30 seconds exceeded in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 230


PS: My english konwledges, sorry, but increase will say: 'more great' like "0" for unlimited??

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Warning-Message
« Reply #3 on: November 28, 2006, 11:29:27 PM »
You got time out error this time again:
Quote
Fatal error: Maximum execution time of 30 seconds exceeded in /data/members/paid/s/c/schreiben-im-netz.com/htdocs/werkstatt/generator/pages/class.grab.inc.php(2) : eval()'d code on line 230
Quote
PS: My english konwledges, sorry, but increase will say: 'more great' like "0" for unlimited??
Yes, you should set a higher value for max_execution_time setting, but it should be applied not in Sitemap Generator configuration, but in PHP config (php.ini file) at your server.

Otherwise, you can repeat the resuming step multiple times until full sitemap is created.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2