XML Sitemaps Generator

Author Topic: XML not being generated  (Read 10606 times)

cmitts

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
XML not being generated
« on: June 15, 2015, 01:54:40 PM »
Hello,

When I crawl my site, the HTML and text formats are generated but XML is not.  This is really important because we need the XML version.  The file exists as a 0 byte file with 777 permissions in a fully writable directory.

Please be aware that I've seen support request info about the site; ours is internal and will not be accessible by your support.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: XML not being generated
« Reply #1 on: June 16, 2015, 03:13:48 AM »
Hello,

what defined in your "Save sitemap to" setting?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

cmitts

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: XML not being generated
« Reply #2 on: June 16, 2015, 01:54:02 PM »
Hello,

It is saving to a subdirectory of the root of our website; the HTML and TXT generate in this directory without issue.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: XML not being generated
« Reply #3 on: June 17, 2015, 10:18:53 AM »
Please try to set 666 permissions to it.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

cmitts

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: XML not being generated
« Reply #4 on: June 18, 2015, 04:13:31 PM »
It has been set to 666 from the beginning, also the sitemap.html file is 644 and has not had any issue.  The owner and group of all files is daemon.  The entire directory structure up to the installation folder is set to 777.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: XML not being generated
« Reply #5 on: June 19, 2015, 06:09:31 AM »
Hello,

is your server Linux or Windows based?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

cmitts

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: XML not being generated
« Reply #6 on: June 22, 2015, 01:54:56 PM »
All of our servers are Red Hat 6.6

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: XML not being generated
« Reply #7 on: June 22, 2015, 03:17:45 PM »
Hello,

replied to your email.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

cmitts

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: XML not being generated
« Reply #8 on: June 22, 2015, 06:56:57 PM »
Thank you, support fixed the issue

For those wondering, Save sitemap to: cannot be pointing to generator/data; you need to have that XML filed specified in just the generator directory, then it will copy it to generator/data when completed.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2