Error since upgrading to https
« on: January 29, 2017, 09:30:08 PM »
There was an error while retrieving the URL specified: https://healthcentre.nz/
HTTP Code:

HTTP headers:
x_csize: 0

HTTP output:
Re: Error since upgrading to https
« Reply #1 on: January 30, 2017, 06:34:59 AM »
Probably there is a configuration problem - it looks like your server doesn't allow local network connections via port 80 (http) or 443 (https) - as a result sitemap generator is not able to crawl the site. This is usually related to firewall installed at the host - could you please contact your hosting support regarding this?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Error since upgrading to https
« Reply #2 on: February 18, 2017, 10:44:37 AM »
Hi,

We discovered the cause of the error. We are using Plesk 12.5 on Debian.

PHP cURL is not using an updated set of root certificates to verify server certs.

Around early September 2014, Mozilla removed the trust bits from the certs in their CA bundle that were still using RSA 1024 bit keys. This may lead to TLS libraries having a hard time to verify some sites if the library in question doesn't properly support "path discovery" as per RFC 4158. (That includes OpenSSL and GnuTLS.)

Resolution

Download the cacert.pem file from the main curl website http://curl.haxx.se/ca/cacert.pem .

Add the following into php.ini or add into 'Additional directives' under Websites & Domains > PHP settings :

curl.cainfo = /var/www/vhosts/WebSite.com/httpdocs/cacert.pem

Voila it now all works.

Regards
Michael
« Last Edit: February 18, 2017, 10:49:29 AM by michaelstuartkelly »
Re: Error since upgrading to https
« Reply #3 on: February 18, 2017, 01:51:42 PM »
Hello,

thank you very much for this update and details on how the issue was resolved.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.