Need help - incorrect header content-type error
« on: February 27, 2019, 05:23:17 PM »
Hi there,

I am a new customer.  Recently bought your software package for my site.

I have created three sitemaps (sitemap.xml, sitemap_news.xml, sitemap_images.xml).

I can load all three in a browser.  However when i submit to Google I get the following error message...
   
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

General HTTP error: HTTP 403 error (Forbidden)
HTTP Error: 403


I have used your Sitemap validator and it has returned the following error....

Incorrect http header content-type: "" (expected: "application/xml")

I am wondering if I have a configuration problem in my set-up?  I am looking for some help in making my sitemaps valid.  Any suggestions?

Thanks in advance
Re: Need help - incorrect header content-type error
« Reply #1 on: February 28, 2019, 05:20:16 AM »
Hello,

what is the link to your sitemap?
Re: Need help - incorrect header content-type error
« Reply #2 on: February 28, 2019, 01:38:31 PM »
Thank you for your response...

[ External links are visible to forum administrators only ]
[ External links are visible to forum administrators only ]
[ External links are visible to forum administrators only ]
Re: Need help - incorrect header content-type error
« Reply #3 on: February 28, 2019, 03:48:36 PM »
Hello,

I just tried and no errors were reported:
check No issues detected
Characer Set   UTF-8
Sitemap is valid   Yes
Warnings   -
Errors   -
Re: Need help - incorrect header content-type error
« Reply #5 on: March 01, 2019, 05:18:12 AM »
Hello,

there was a mistyping in the sitemap link: you have ww.domain.com (with 2 "w"), while it should be "[ External links are visible to forum administrators only ]" (with 3 "w").
Re: Need help - incorrect header content-type error
« Reply #6 on: March 01, 2019, 01:37:11 PM »
My apologies on the typo.  I am pretty sure I had earlier typed it in properly and it returned the error. 

sitemap.xml
Nice to see that sitemap.xml it is now valid.   That said, when I submit to google i get the following error message...
   
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

General HTTP error: HTTP 403 error (Forbidden)
HTTP Error: 403


Please advise why I am getting this error message from google.

sitemap_news.html
When I try to validate sitemap_news.xml, I get the incorrect header error

https://www.xml-sitemaps.com/validate-xml-sitemap.html?op=validate-xml-sitemap&go=1&sitemapurl=http%3A%2F%2Fwww.ourhometown.ca%2Fsitemap_news.xml&submit=Validate+Sitemap

Please advise why this sitemap wont validate and if I will still encounter the problem above with google.

sitemap_images.xml
Nice to see that sitemap.xml it is now valid.   That said, when I submit to google i get the following error message...
   
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

General HTTP error: HTTP 403 error (Forbidden)
HTTP Error: 403


Please advise why I am getting this error message from google.

I really appreciate your help here!  Looking forward to your reply.

Re: Need help - incorrect header content-type error
« Reply #7 on: March 01, 2019, 07:44:07 PM »
Hello,

looks like your host blocks requests from googlebot for some reason, you need to check this.