XML Sitemaps Generator

Author Topic: 0 pages indexed, robots.txt appears fine  (Read 14293 times)

sunexos

  • Approved member
  • *
  • Posts: 2
0 pages indexed, robots.txt appears fine
« on: June 14, 2011, 03:36:39 PM »
The sitemap generates fine, but this is all I get

<?xml version="1.0" encoding="UTF-8"?>
<urlset
      xmlns="[external links are visible to admins only]"
      xmlns:xsi="[external links are visible to admins only]"
      xsi:schemaLocation="[external links are visible to admins only]
            [external links are visible to admins only]">
<!-- created with Free Online Sitemap Generator www.xml-sitemaps.com -->

</urlset>

 There is a line in there

User-agent: *
Disallow:
Disallow: /cgi-bin/

But no / in front of anything so I assumed that I'm not blocking the entire site. 

Any ideas

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: 0 pages indexed, robots.txt appears fine
« Reply #1 on: June 15, 2011, 08:12:55 AM »
Hello,

what is your site URL?
You can use SE bot simulator to check if your pages are "crawlable": http://www.xml-sitemaps.com/se-bot-simulator.html
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

sunexos

  • Approved member
  • *
  • Posts: 2
Re: 0 pages indexed, robots.txt appears fine
« Reply #2 on: June 16, 2011, 12:20:59 PM »
[external links are visible to admins only]

It's a WP site and I've never had this much trouble with a WP site before.  I installed a WP plugin to generate a sitemap and finally got it to make one showing all the pages, but this sitemap generator still wont work.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: 0 pages indexed, robots.txt appears fine
« Reply #3 on: June 16, 2011, 12:28:26 PM »
Hello,

as reported by SE bot simulator you have all your pages blocked with nofollow attribute:
http://www.xml-sitemaps.com/se-bot-simulator.html?op=se-bot-simulator&go=1&pageurl=http%3A%2F%2Frwmma.com%2F&se=googlebot&submit=Start

you should remove this from your pages:
<meta name="robots" content="noindex, nofollow" />
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2